troubles trying to boot program from flash memory

we still have many troubles trying to load program in the flash memory of our DSP boards. It often does not work, but sometimes (less than 1% of the times) worked... Even a very simple program generally does not load into flash. We asked a couple of months ago for your help, and thanks to the informations you gave us it worked at that time. It sometimes worked since, but it is simply random : it sometimes works, very often does not work, and we don't know why. I just do not understand at the moment.

I have been trying all the afternoon to load a very simple VisSim program into the flash memory (the same I sent you a couple of months ago), and it didn't work. The program successfully runs on the DSP RAM memory. Each time, CCS seems to successfully load the program into flash (it answers Erase/Program/verify operation succeeded). After having loaded program into Flash with CCS, we power off the board, and then turn it on again. We expect the DSP to automatically launch the program loaded into flash, but it does not work (or rather rarely works).

I have attached you the Vissim file we use, the DSP files generated (.c and .out), and the configuration we use to generate code and to load the program into flash. I am trying to understand why flashing rarely works, what we are doing wrong. Do you have any idea ?

Thank you for your help,

Regards,

Alix

You must tie GPIO 18,29 & 34 high

1) If you are using eZdsp, then OSCCLK is 20 MHZ. CLKINDIV must be 1 and PLLCR = 5. In your screen shot you show OSCCLK = 40 MHZ.

2) When you repower the board after flashing, GPIO18,29 and 34 must be tied high to force boot to flash. If not, the chip will try to boot from another peripheral (See TI doc spru722b.pdf).

It works now, thanks.

Hi,

we have forced high GPIO 18, 29 and 34 at board start-up, and it now boots correctly on the flash memory.

Thank you for your help,