TI Error

I am trying to run some .vsm files mostly with CAN stuff in them and I am having different results from time to time. Which I think and hope are coming from this error that comes up every once and a while the error is as follows. TI driver error -2134, TRG_ERR_EXEC_PTI

This is so strange I have

This is so strange I have used 2 USB Cables and I have used XDS100 and two different experimenter kits using there onboard Emulators. And I get the exactly the same outcome. I am starting to wonder if there is a problem with the computer with the USB Ports or the power to them but my PCAN device is working fine.

What version of Windows do

What version of Windows do you have? We have some XP boxes that have had their USB driver screwed up so that the TI JTAG drivers don't work. In fact, when the USB JTAG is plugged into this machine, the JTAG shows up as "unknown device" in the list of USB connections on those machines. We have not seen this problem under Win 7. If you run Control Panel > System > Device Manager, what do you see under USB controllers when your JTAG is plugged in? You should see something like "TI XDS100 Channel A" & B for XDS100.

It is Windows XP and I have

It is Windows XP and I have seen a device manager problem once that showed a Jtag that we don't even own but I got rid of it and it hasn't come back when I check now it says Channel A and Channel B like you said. The computer that I am using is a spare while my laptop is in getting repaired I am thinking of formating the HD and starting from scratch or trying a different computer.

I checked the CCS connection

I checked the CCS connection and it is dead I even restarted my computer and tried to connect to a inverter with a known good 28335 on it and also tried a experimenter kit with a 28335 card in it using the onboard Jtag which I also know as good. This just all the sudden started happening for no good reason. The highest power any of this stuff has been around is maybe 800 watts at most. I tried reinstalling CCS5 but it didn't help and I cant reinstall Vissim because I am still on the Trial hopfully not for long though. When I compile there is a warning that comes up right near the end that says "Ink2000 not recognized as an internal or external command". Could this be part of the problem I have been watching the builds and have not seen it before.

What kind of JTAG emulator

What kind of JTAG emulator are you using? Try switching out the USB cable, we've seen those go bad.

Your "Ink2000 not recognized as an internal or external command" error is due to reinstalling CCS to a different location. VisSim links to the CCS compiler by setting the CCS compiler path into a compile batch file when you installed it. However it is easy to update the .bat file that sets the compiler path. For F280x/F283x the file is \vissim80\cg\dosrun28.bat. Just change the line
set CG5DIR=C:\TI5\ccsv5\tools\compiler\c2000
in the file to match the path to your c2000 compiler.

Unfortunately the "link" error has nothing to do with your failed JTAG.

This error comes from the

This error comes from the JTAG emulator used to download and communicate with the target. There are several reasons you can get this error.

  1. You are running Code Composer and have an active debug session going on it. The TI JTAG drivers only support one application connection at a time. You will have to exit Code Composer and VisSim both. You may have to kill the process "javaw.exe" and "eclipse.exe" to truly rid yourself of the Code Composer connection.
  2. You have the wrong JTAG emulator selected under MCU Config...
  3. The power has failed on the target device.
  4. The USB cable has become dislodged.
  5. Your device under control is connected to a high power device like a motor controller and you don't have adequate isolation in the USB connection.