Issues with Building a VisSim project with Code Composer Studio v5

I am running Vissim version 8.0C0 - target processor TI2806 I would like to take this same project (the exported .C file), bring into Code Composer 5.0, and build it.

I found a forum regarding this topic at: http://www.vissim.com/forums/vissim_code_composer_studio_plug-_not_insta...

I have done all the proper steps that were listed in the forum, built my project from Code Composer 5, but I am getting several errors: Here's an example of one group of them:

#145 a value of type "ARG_DESCR *" cannot be used to initialize an entity of type "CGDOUBLE"
#145 a value of type "DATA_FILE_INFO *" cannot be used to initialize an entity of type "XFERFUN_INFO *"
#145 a value of type "int" cannot be used to initialize an entity of type "ARG_DESCR *" 
#145 a value of type "int" cannot be used to initialize an entity of type "CGDOUBLE *"  
#145 a value of type "int" cannot be used to initialize an entity of type "IVECTOR *"
#145 a value of type "int" cannot be used to initialize an entity of type "TIME_DELAY_INFO *"
#145 a value of type "int" cannot be used to initialize an entity of type "VECTOR *"

Q1. In regards to the original Vissim project, when I export the C file, are there any specific steps I need to do?

Q2. In regards to the errors listed above, is there an include file or DLL or any other type of file that I am currently not including that would initialize the values properly (ex. CGDOUBLE, ASG_DESCR, etc).

Q3. In regards to Code Composer 5, am I missing any other link paths, include libraries, etc?

Thanks - but, getting another error

Thanks for the response! Now that I have added the "_SMALL_RAM " option, and linking the "/vissim80/cg/lib/ii_f280xSR.lib", the original list of errors has now cleared up.

But, now I am getting the following:

#6001 -  cannot open file "/vissim80/cg/lib":, Permission denied

Any ideas why this error is popping up?

6001 - cannot open file "/vissim80/cg/lib":, Permission denied

I double checked the project properties and made SURE I had all the proper links setup for: "/vissim80/cg/lib"

They all seem to be correct. Any ideas?

From the error messages, it

From the error messages, it looks like you generated the code with the "Minimize RAM usage" option checked. This means that you must define the preprocessor name _SMALL_RAM to compile properly. (If you don't check the option, then don't define _SMALL_RAM). The good news is that your header file search paths appear to be set up correctly. You must also link with the small RAM version of the VisSim RTOS support library: ii_F280xSR.lib
There are 4 possible libraries you link with depending if you are targeting small RAM usage or a part with hardware FPU or both:

VisSim RTOS support Lib Target has FPU Minimize RAM
ii_f280x.lib no no
ii_f280x_fpu.lib yes no
ii_f280xSR.lib no yes
ii_f280x_fpuSR.lib yes yes