incompatible runtime models (msp430)

I get this error when I compile the msp430 fan pgm Error[e117]:incompatible runtime models. Module fanmsp430 specifies that '__systemlibrary' must be 'dlib',but module?calloc has the value 'clib'

Are you using IAR? This

Are you using IAR? This compiles and links fine for CCS. If you are using IAR Workbench, what version are you using?